<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />
<meta name="viewport" content="width=device-width" /> 	<link rel="Shortcut Icon" href="https://www.hamlineoracle.com/wp-content/uploads/2016/09/favicon.png" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The Oracle RSS 2.0" href="https://www.hamlineoracle.com/feed/" />
<link rel="alternate" type="text/xml" title="The Oracle RSS .92" href="https://www.hamlineoracle.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The Oracle Atom 0.3" href="https://www.hamlineoracle.com/feed/atom/" />

<title>Staff Editorial: In response to George Floyd &#8211; The Oracle</title>
<link rel="alternate" type="application/rss+xml" title="The Oracle &raquo; Staff Editorial: In response to George Floyd Comments Feed" href="https://www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.hamlineoracle.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			<style type="text/css">
				</style>
	<link rel='stylesheet' id='farbtastic-css'  href='https://www.hamlineoracle.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.hamlineoracle.com/wp-includes/css/dashicons.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.hamlineoracle.com/wp-includes/js/thickbox/thickbox.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://www.hamlineoracle.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.hamlineoracle.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://www.hamlineoracle.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.hamlineoracle.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.hamlineoracle.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.hamlineoracle.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family&#038;display=swap&#038;ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://www.hamlineoracle.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://www.hamlineoracle.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://www.hamlineoracle.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://www.hamlineoracle.com/wp-content/themes/snoflex/style.css?ver=20200596' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://www.hamlineoracle.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.8' type='text/css' media='screen' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.hamlineoracle.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/www.hamlineoracle.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20200505'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.4.1'></script>
<link rel='https://api.w.org/' href='https://www.hamlineoracle.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.hamlineoracle.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.hamlineoracle.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='PHOTO GALLERY: Updates from the Twin Cities Community' href='https://www.hamlineoracle.com/7691/news/updates-from-the-twin-cities-community/' />
<meta name="generator" content="WordPress 5.4.1" />
<link rel="canonical" href="https://www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd/" />
<link rel='shortlink' href='https://www.hamlineoracle.com/?p=7705' />
<link rel="alternate" type="application/json+oembed" href="https://www.hamlineoracle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.hamlineoracle.com%2F7705%2Fopinion%2Fstaff-editorial-in-response-to-george-floyd%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.hamlineoracle.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.hamlineoracle.com%2F7705%2Fopinion%2Fstaff-editorial-in-response-to-george-floyd%2F&#038;format=xml" />


<!-- Start of Facebook Meta Tags -->

<meta property="og:title" content="Staff Editorial: In response to George Floyd" />
<meta property="og:type" content="article" />
<meta name="author" content="Oracle Staff" />
<meta property="og:url" content="https://www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd/" />
<meta property="og:image" content="https://www.hamlineoracle.com/wp-content/uploads/2016/09/web_title_1617-01-3.png" />
	<meta property="og:site_name" content="The Oracle" />
	<meta property="og:description" content="This last week has been very turbulent not only for the state of Minnesota but also for the nation and world as a whole. On Monday, May 25th the Twin Cities saw, again, the death of a black man from police brutality. This is a real, systemic issue that exists in the community Hamline University..." />
	<meta name="description" content="This last week has been very turbulent not only for the state of Minnesota but also for the nation and world as a whole. On Monday, May 25th the Twin Cities saw, again, the death of a black man from police brutality. This is a real, systemic issue that exists in the community Hamline University..." />
	<meta property="article:section" content="Opinion" />
	<meta property="article:tag" content="George Floyd,opinion,staff editorial,twin cities" />
<!-- End of Facebook Meta Tags -->

<script type="text/javascript" src="https://www.hamlineoracle.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1591468855"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->


<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body data-rsssl=1><div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft social-classic">
				<style>.topnavbarleft { padding: 0px; width:auto; }</style><a target="_blank" href="https://www.hamlineoracle.com/feed/rss/"><div class="alt-header-social social-border sno-rss dashicons dashicons-rss"><span class="icon-hidden-text">RSS Feed</span></div></a><a target="_blank" href="https://vimeo.com/hamlineoracle">
        		<div class="alt-header-social-fa social-border sno-vimeo fa fa-vimeo"><span class="icon-hidden-text">Vimeo</span></div>
        	</a><a target="_blank" href="https://www.instagram.com/hamlineoracle/">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a target="_blank" href="https://twitter.com/HamlineOracle">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a target="_blank" href="https://www.facebook.com/HamlineOracle">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div>			</div>

			<div class="topnavbarcenter">
        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform5231" action="https://www.hamlineoracle.com/">
			<div class="search-button-container" id="searchthis5231">
			<button type="submit" disabled="disabled" id="sno-search-navbar-5231" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s5231" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s5231" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit5231" style="display:none;" value="Search" />
		</form>
				</div>
	</div>
	<div class="clear"></div>
</div><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon foundation-icons fi-x"><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://www.hamlineoracle.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="menu"><ul>
<li class="page_item page-item-25"><a href="https://www.hamlineoracle.com/about/">About the Oracle</a></li>
<li class="page_item page-item-5355"><a href="https://www.hamlineoracle.com/apply-here/">Apply here</a></li>
<li class="page_item page-item-1822"><a href="https://www.hamlineoracle.com/contact/">Contact</a></li>
<li class="page_item page-item-2030"><a href="https://www.hamlineoracle.com/currentpoll/">Current Poll</a></li>
<li class="page_item page-item-7370"><a href="https://www.hamlineoracle.com/magazine-archive/">Magazine Archive</a></li>
<li class="page_item page-item-182"><a href="https://www.hamlineoracle.com/pollsarchive/">pollsarchive</a></li>
<li class="page_item page-item-24"><a href="https://www.hamlineoracle.com/staff/">Staff</a></li>
</ul></div>
</ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://www.hamlineoracle.com/wp-content/uploads/2016/09/web_title_1617-01-3.png" class="headerimage" alt="The student news site of Hamline University." /></div><div class="headerlink headermedium" style="display:none"><img src="https://www.hamlineoracle.com/wp-content/uploads/2016/09/web_title_1617-01-3.png" class="headerimage" alt="The student news site of Hamline University." /></div><div class="headerlink headerlarge"><img src="https://www.hamlineoracle.com/wp-content/uploads/2016/09/web_title_1617-01-3.png" class="headerlink headerimage" alt="The student news site of Hamline University." /></div><h1 style="display:none" aria-hidden="true">The Oracle</h1><script type="text/javascript">
						jQuery(document).ready(function(){
							jQuery(".headerlink").click(function(){
								window.location="https://www.hamlineoracle.com";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://www.hamlineoracle.com"><img src="https://www.hamlineoracle.com/wp-content/uploads/2016/09/web_title_1617-01-3.png" class="headerimage" alt="The student news site of Hamline University." /></a></div><h1 style="display:none">The Oracle</h1></div></div><div class='navbarwrap'
						data-align='left' 
						data-margin='0' 
						data-style='Bar' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='970'><div class="navbarcontainer"><div id="navbar"><div id="navbarbackground"><div id="menu-a-menu"><nav aria-label="Secondary Menu"><div class="menu-extra-pages-container"><ul id="menu-extra-pages" class="sf-menu sno-top-menu"><li id="menu-item-170" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170"><a href="/">Home</a></li>
<li id="menu-item-7571" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7571"><a href="https://www.hamlineoracle.com/category/covid19/">COVID-19</a></li>
<li id="menu-item-4506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4506"><a href="https://www.hamlineoracle.com/category/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li id="menu-item-4503" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4503"><a href="https://www.hamlineoracle.com/category/news/">News</a></li>
<li id="menu-item-4505" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4505"><a href="https://www.hamlineoracle.com/category/opinion/">Opinion</a></li>
<li id="menu-item-4504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4504"><a href="https://www.hamlineoracle.com/category/sports/">Sports</a></li>
<li id="menu-item-4507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4507"><a href="https://www.hamlineoracle.com/category/variety/">Variety</a></li>
<li id="menu-item-172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-172"><a href="https://www.hamlineoracle.com/staff/">Staff</a></li>
<li id="menu-item-171" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171"><a href="https://www.hamlineoracle.com/about/">About The Oracle</a></li>
<li id="menu-item-5358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5358"><a href="https://www.hamlineoracle.com/apply-here/">Apply here</a></li>
<li id="menu-item-7387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7387"><a href="https://www.hamlineoracle.com/magazine-archive/">Magazine Archive</a></li>
</ul></div></nav></div><ul id='menu-more-top' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-top" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
								<ul id="add-more-top" class="sub-menu"></ul>
								</li>
							</ul></div></div></div></div><div class="clear"></div>
					<script type="text/javascript">
/*
						jQuery('#navbar').css("overflow-y", "hidden");
						jQuery(window).load(function() {
							if (jQuery( window).width() < 980) { return; }	
							resizeMenuTop();
						})
												
						function resizeMenuTop() {
							
							if (jQuery( window).width() < 980) { return; }
	
							var moreWidthTop = 0; var menubufferTop = 0; var minilogoTop = 0;
	
							if (jQuery('#menu-more-top').is(':visible')) { moreWidthTop = jQuery('#menu-more-top').width(); }			
																																				var MenuTopWidth = 970;
															var browserWidth = jQuery(window).width();
								if (browserWidth < MenuTopWidth) MenuTopWidth = browserWidth;
								
							
							if (jQuery('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop >= MenuTopWidth) 
							{ 
								jQuery('.sno-top-menu > li:last-child').addClass('sub-menu'); 
								jQuery('.sno-top-menu > li:last-child').appendTo('#add-more-top'); 
								if (jQuery('#menu-more-top').is(':hidden')) { jQuery('#menu-more-top').css({display: "block"}); }			
								if (jQuery('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop > MenuTopWidth) {
									resizeMenuTop(); 
								} else {
									jQuery('#navbar').css("overflow-y", "unset");
									resizeMenuTop(); 
								}
							} else {
								jQuery('#navbar').css("overflow-y", "unset");								
							}
							 
						}
	            		jQuery( window ).resize(function() { 
	             	   		if (jQuery( window).width() > 980) { resizeMenuTop(); };
	            		});   
*/
	 				</script>
	 			<div class="bottom-menu"><div class='subnavbarwrap sno-sticky'
						data-align='left' 
						data-margin='0' 
						data-style='Bar' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='970'><div class="subnavbarcontainer"><div id="subnavbar"><div id="subnavbarbackground"><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-extra-pages-container"><ul id="menu-extra-pages-1" class="sf-menu sno-bottom-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-170"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7571"><a href="https://www.hamlineoracle.com/category/covid19/">COVID-19</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4506"><a href="https://www.hamlineoracle.com/category/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4503"><a href="https://www.hamlineoracle.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4505"><a href="https://www.hamlineoracle.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4504"><a href="https://www.hamlineoracle.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4507"><a href="https://www.hamlineoracle.com/category/variety/">Variety</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-172"><a href="https://www.hamlineoracle.com/staff/">Staff</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-171"><a href="https://www.hamlineoracle.com/about/">About The Oracle</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5358"><a href="https://www.hamlineoracle.com/apply-here/">Apply here</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7387"><a href="https://www.hamlineoracle.com/magazine-archive/">Magazine Archive</a></li>
</ul></div></nav><div class="clear"></div></div><ul id='menu-more-bottom' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-bottom" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
							<ul id="add-more-bottom" class="sub-menu"></ul>
							</li>
						</ul></div><div class="clear"></div></div></div></div></div><div class="clear"></div><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap"><div class="innerbackground"><div id='snopostid-7705' class='snopostid'><div id='classic_story' class='sno-story-7705'><div id="content"><div id='contentleft'><div class="postarea"><ul class="snocategories"><li class='blockscategory'><a href='https://www.hamlineoracle.com/category/opinion/' rel='category tag'>Opinion</a></li></ul><div role="main"><h1 class="storyheadline">Staff Editorial: In response to George Floyd</h1><div class="clear"></div><div class="permalinkphotobox"><div class="clear"></div><div class="photobottom"></div></div><div class="storydetails"><p><span class="storybyline"> Oracle Staff</span><br /><span class="storydate"><span class="time-wrapper">June 5, 2020</span></span></p></div><div class="sharing sharing-top" data-story-id="7705"><a class='commentscroll' href='https://www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-show'><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.hamlineoracle.com%2F7705%2Fopinion%2Fstaff-editorial-in-response-to-george-floyd%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Staff Editorial: In response to George Floyd&amp;url=https%3A%2F%2Fwww.hamlineoracle.com%2F%3Fp%3D7705" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div><span class="storycontent"><p><span data-preserver-spaces="true">This last week has been very turbulent not only for the state of Minnesota but also for the nation and world as a whole. On Monday, May 25th the Twin Cities saw, again, the death of a black man from police brutality. This is a real, systemic issue that exists in the community Hamline University calls home. According to data collected by Mapping Police Violence, black people are killed at 6.1x the rate as white people by the St. Paul Police Department and 13.2x the rate as white people by the Minneapolis Police Department.  </span></p>
<p><span data-preserver-spaces="true">As Hamline students, we are hurting. We also know these issues impact students in different ways. </span></p>
<p><span data-preserver-spaces="true">The </span><em><span data-preserver-spaces="true">Oracle </span></em><span data-preserver-spaces="true">has been published by Hamline students since 1888 and we are committed to reporting clear and accurate news. This means we will continue to provide the Twin Cities and Hamline community with updates and information we believe is necessary for all. </span></p>
<p><span data-preserver-spaces="true">The </span><em><span data-preserver-spaces="true">Oracle</span></em><span data-preserver-spaces="true"> stands with students of color. The </span><em><span data-preserver-spaces="true">Oracle</span></em><span data-preserver-spaces="true"> stands with black students. As addressed by Hamline Undergraduate Student Congress (HUSC), Hamline offers resources for all students to utilize. This includes: </span></p>
<p><span data-preserver-spaces="true">Hedgeman Center for Student Diversity Initiatives (hedgeman@hamline.edu)</span></p>
<p><span data-preserver-spaces="true">Wesley Center (wesleycenter@hamline.edu) </span></p>
<p><span data-preserver-spaces="true">Dean of Students (deanofstudents@hamline.edu)</span></p>
<p><span data-preserver-spaces="true">Office of Inclusive Excellence (hofficeofinclusivexcellence01@hamline.edu) </span></p>
<p><span data-preserver-spaces="true">Health and Counseling Services (counselinghealth@hamline.edu)</span></p>
<p><span data-preserver-spaces="true">Hamline Undergraduate Student Congress (husc@hamline.edu) </span></p>
<p><span data-preserver-spaces="true">We send our deepest condolences to the Floyd family as well as all families who have been affected by police violence. It is important to recognize the systems of oppression that we perpetuate in our lives. The </span><em><span data-preserver-spaces="true">Oracle</span></em><span data-preserver-spaces="true"> has a history of amplifying privileged voices whether that be intentional or not. We acknowledge this and will fight to lift these stories so all voices are heard.  </span></p>
<p><span data-preserver-spaces="true">Your editors, </span></p>
<p><b>Carmen Danz</b><b>    </b><b> Sabrina Merritt</b></p>
<p>Editor-in-chief      Managing Editor</p>
</span><div class="clear"></div></div><ul class="snotags"><li class="blockstag"><a href="https://www.hamlineoracle.com/tag/george-floyd/" rel="tag">George Floyd</a></li><li class="blockstag"><a href="https://www.hamlineoracle.com/tag/opinion/" rel="tag">opinion</a></li><li class="blockstag"><a href="https://www.hamlineoracle.com/tag/staff-editorial/" rel="tag">staff editorial</a></li><li class="blockstag"><a href="https://www.hamlineoracle.com/tag/twin-cities/" rel="tag">twin cities</a></li></ul></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="true" class="commenttoggle fa fa-minus-square"></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id='commentsbody' class='widgetbody' style='display:block;'>


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">

If you want a picture to show with your comment, go get a <a href="http://en.gravatar.com" >gravatar</a>.</p>





<form action="https://www.hamlineoracle.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="7705" /></p>



<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="99"/></p>
<div id="captchaImgDiv">

<div class="si_captcha_small"><img id="si_image_com" src="https://www.hamlineoracle.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix=F81T9TJEi3wNb3Il" width="132" height="45" alt="CAPTCHA" title="CAPTCHA" />
    <input id="si_code_com" name="si_code_com" type="hidden"  value="F81T9TJEi3wNb3Il" />
    <div id="si_refresh_com">
<a href="#" rel="nofollow" title="Refresh" onclick="si_captcha_refresh('si_image_com','com','/wp-content/plugins/si-captcha-for-wordpress/captcha','https://www.hamlineoracle.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix='); return false;">
      <img class="si_captcha_refresh" src="https://www.hamlineoracle.com/wp-content/plugins/si-captcha-for-wordpress/captcha/images/refresh.png" width="22" height="20" alt="Refresh" onclick="this.blur();" /></a>
  </div>
  </div>

<p id="si_captcha_code_p">
<input id="si_captcha_code" name="si_captcha_code" type="text" />
<label for="si_captcha_code" >CAPTCHA Code</label><span class="required"> *</span>
</p>
</div>
      <script type='text/javascript'>
          var sUrlInput = document.getElementById("comment");
                  var oParent = sUrlInput.parentNode;
          var sSubstitue = document.getElementById("captchaImgDiv");
                  oParent.appendChild(sSubstitue, sUrlInput);
      </script>
            <noscript>
          <style type='text/css'>#submit {display:none;}</style><br />           <input name="submit" type="submit" id="submit-alt" tabindex="6" value="Submit Comment" />
          </noscript>
  


</form>









</div></div><div class="widgetfooter"></div></div></div></div><div id="sidebar"><div class='snoadnetwork'>
	<div class='advertisementwrap'>
		<div class='sidebar-ad'>
			<script type="text/javascript">
				jQuery(document).ready(function( $ ) {
					retreive_ad();
					$('.sidebar-ad').on('click', '.sno-ad', function() {
						let ad_id = $(this).data('ad-id');
						url = 'https://snoads.com/api/v1/ad/' + ad_id + '/click';
						jQuery.post(url, '', function(response) {
							console.log(response);
				        });
					});

					$('.sidebar-ad').on('click', '.sno-fill-ad', function() {
						url = 'https://snoads.com/site/409';
						window.open(url, '_blank');
					});

			        function retreive_ad() {
			        	var url = 'https://snoads.com/api/v1/adspot/557/serve'
			        	var fill_ad = "";
						jQuery.get(url, '', function(response) {
							if (response) {
								$('.sidebar-ad').html('<a target="_blank" href="' + response.link.link + '" class="sno-ad" data-ad-id="' + response.id + '"><img src="' + response.image.url + '" /></a>');
							} else if (fill_ad) {
								$('.sidebar-ad').html('<img class="sno-fill-ad" src="' + fill_ad + '" />');
							} else {
								let rand_num = Math.floor((Math.random() * 2) + 1);
								$('.sidebar-ad').html('<img class="sno-fill-ad" src="https://snoads.s3.amazonaws.com/sno_ad_fill/300x250_' + rand_num + '.jpg" />');
							}
				        });
			        }
				});
			</script>
		</div>
	</div>
</div>
<div class="clear"></div><div style="clear:both"></div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Archives</div></div><div class="widgetbody">		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://www.hamlineoracle.com/date/2020/06/'> June 2020 </option>
	<option value='https://www.hamlineoracle.com/date/2020/05/'> May 2020 </option>
	<option value='https://www.hamlineoracle.com/date/2020/04/'> April 2020 </option>
	<option value='https://www.hamlineoracle.com/date/2020/03/'> March 2020 </option>
	<option value='https://www.hamlineoracle.com/date/2020/02/'> February 2020 </option>
	<option value='https://www.hamlineoracle.com/date/2019/12/'> December 2019 </option>
	<option value='https://www.hamlineoracle.com/date/2019/11/'> November 2019 </option>
	<option value='https://www.hamlineoracle.com/date/2019/10/'> October 2019 </option>
	<option value='https://www.hamlineoracle.com/date/2019/09/'> September 2019 </option>
	<option value='https://www.hamlineoracle.com/date/2019/05/'> May 2019 </option>
	<option value='https://www.hamlineoracle.com/date/2019/04/'> April 2019 </option>
	<option value='https://www.hamlineoracle.com/date/2019/03/'> March 2019 </option>
	<option value='https://www.hamlineoracle.com/date/2019/02/'> February 2019 </option>
	<option value='https://www.hamlineoracle.com/date/2018/12/'> December 2018 </option>
	<option value='https://www.hamlineoracle.com/date/2018/11/'> November 2018 </option>
	<option value='https://www.hamlineoracle.com/date/2018/10/'> October 2018 </option>
	<option value='https://www.hamlineoracle.com/date/2018/09/'> September 2018 </option>
	<option value='https://www.hamlineoracle.com/date/2018/05/'> May 2018 </option>
	<option value='https://www.hamlineoracle.com/date/2018/04/'> April 2018 </option>
	<option value='https://www.hamlineoracle.com/date/2018/03/'> March 2018 </option>
	<option value='https://www.hamlineoracle.com/date/2018/02/'> February 2018 </option>
	<option value='https://www.hamlineoracle.com/date/2017/12/'> December 2017 </option>
	<option value='https://www.hamlineoracle.com/date/2017/11/'> November 2017 </option>
	<option value='https://www.hamlineoracle.com/date/2017/10/'> October 2017 </option>
	<option value='https://www.hamlineoracle.com/date/2017/09/'> September 2017 </option>
	<option value='https://www.hamlineoracle.com/date/2017/04/'> April 2017 </option>
	<option value='https://www.hamlineoracle.com/date/2017/03/'> March 2017 </option>
	<option value='https://www.hamlineoracle.com/date/2017/02/'> February 2017 </option>
	<option value='https://www.hamlineoracle.com/date/2016/12/'> December 2016 </option>
	<option value='https://www.hamlineoracle.com/date/2016/11/'> November 2016 </option>
	<option value='https://www.hamlineoracle.com/date/2016/10/'> October 2016 </option>
	<option value='https://www.hamlineoracle.com/date/2016/09/'> September 2016 </option>
	<option value='https://www.hamlineoracle.com/date/2016/05/'> May 2016 </option>
	<option value='https://www.hamlineoracle.com/date/2016/04/'> April 2016 </option>
	<option value='https://www.hamlineoracle.com/date/2016/03/'> March 2016 </option>
	<option value='https://www.hamlineoracle.com/date/2016/02/'> February 2016 </option>
	<option value='https://www.hamlineoracle.com/date/2015/12/'> December 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/11/'> November 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/10/'> October 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/09/'> September 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/08/'> August 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/07/'> July 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/05/'> May 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/04/'> April 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/03/'> March 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2015/02/'> February 2015 </option>
	<option value='https://www.hamlineoracle.com/date/2014/12/'> December 2014 </option>
	<option value='https://www.hamlineoracle.com/date/2014/11/'> November 2014 </option>
	<option value='https://www.hamlineoracle.com/date/2014/10/'> October 2014 </option>
	<option value='https://www.hamlineoracle.com/date/2014/09/'> September 2014 </option>
	<option value='https://www.hamlineoracle.com/date/2014/05/'> May 2014 </option>
	<option value='https://www.hamlineoracle.com/date/2014/04/'> April 2014 </option>
	<option value='https://www.hamlineoracle.com/date/2014/03/'> March 2014 </option>
	<option value='https://www.hamlineoracle.com/date/2014/02/'> February 2014 </option>
	<option value='https://www.hamlineoracle.com/date/2013/12/'> December 2013 </option>
	<option value='https://www.hamlineoracle.com/date/2013/11/'> November 2013 </option>
	<option value='https://www.hamlineoracle.com/date/2013/10/'> October 2013 </option>
	<option value='https://www.hamlineoracle.com/date/2013/09/'> September 2013 </option>
	<option value='https://www.hamlineoracle.com/date/2013/05/'> May 2013 </option>
	<option value='https://www.hamlineoracle.com/date/2013/04/'> April 2013 </option>
	<option value='https://www.hamlineoracle.com/date/2013/03/'> March 2013 </option>
	<option value='https://www.hamlineoracle.com/date/2013/02/'> February 2013 </option>
	<option value='https://www.hamlineoracle.com/date/2012/12/'> December 2012 </option>
	<option value='https://www.hamlineoracle.com/date/2012/11/'> November 2012 </option>
	<option value='https://www.hamlineoracle.com/date/2012/10/'> October 2012 </option>
	<option value='https://www.hamlineoracle.com/date/2011/12/'> December 2011 </option>
	<option value='https://www.hamlineoracle.com/date/2011/05/'> May 2011 </option>
	<option value='https://www.hamlineoracle.com/date/2010/11/'> November 2010 </option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div><div class="widgetfooter3"></div></div></section></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://www.hamlineoracle.com/7676/opinion/take-responsibility-for-your-privilege/#photo'><img src='https://www.hamlineoracle.com/wp-content/uploads/2019/10/IMG_3118-e1571879930948-434x475.png' id='grow-stb7676'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Take responsibility for your privilege'/></a></div><p class='stb-cat'>Opinion</p><p class="relatedtitle"><a href="https://www.hamlineoracle.com/7676/opinion/take-responsibility-for-your-privilege/">Take responsibility for your privilege</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.hamlineoracle.com/7650/opinion/why-we-need-to-wear-face-masks-and-stay-at-home/#photo'><img src='https://www.hamlineoracle.com/wp-content/uploads/2020/04/DSC_0015-475x317.jpg' id='grow-stb7650'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Juniors Ziqiao Ma and Zhaoying Chen share a moment in the sun outside of Drew Residence Hall, both wearing face masks. '/></a></div><p class='stb-cat'>COVID-19</p><p class="relatedtitle"><a href="https://www.hamlineoracle.com/7650/opinion/why-we-need-to-wear-face-masks-and-stay-at-home/">Why we need to wear face masks and stay at home</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.hamlineoracle.com/7644/opinion/you-should-go-for-a-bicycle-ride/#photo'><img src='https://www.hamlineoracle.com/wp-content/uploads/2020/04/BIKINGPHOTO2-475x317.jpg' id='grow-stb7644'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Bikers, looking to enjoy the fresh weather and forget the quarantine, were out and about near the lakes and Parkway in Minneapolis on April 23, 2020.'/></a></div><p class='stb-cat'>Opinion</p><p class="relatedtitle"><a href="https://www.hamlineoracle.com/7644/opinion/you-should-go-for-a-bicycle-ride/">You should go for a bicycle ride</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.hamlineoracle.com/7642/opinion/taking-advantage-of-distancing/#photo'><img src='https://www.hamlineoracle.com/wp-content/uploads/2019/10/Hugh-Lane-Dublin-City-GAllery-396x475.jpg' id='grow-stb7642'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Taking advantage of distancing'/></a></div><p class='stb-cat'>COVID-19</p><p class="relatedtitle"><a href="https://www.hamlineoracle.com/7642/opinion/taking-advantage-of-distancing/">Taking advantage of distancing</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.hamlineoracle.com/7619/opinion/finding-productivity-during-quarantine/#photo'><img src='https://www.hamlineoracle.com/wp-content/uploads/2019/10/IMG_3377-475x475.jpg' id='grow-stb7619'  style='width:70px;min-width:70px;' class='catboxphoto' alt='Finding productivity during quarantine'/></a></div><p class='stb-cat'>COVID-19</p><p class="relatedtitle"><a href="https://www.hamlineoracle.com/7619/opinion/finding-productivity-during-quarantine/">Finding productivity during quarantine</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

  							//		animation: 'fade',
  							//		smoothHeight: false,
  							//		customDirectionNav: jQuery("#sfi-navigation span"),
  							//		animationLoop: true,
  							//		slideshow: false,
  							//		touch: true



		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div><div style="clear:both;"></div><div class="footerwrap"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://www.hamlineoracle.com">The Oracle</a></p></div><div class="footerright social-classic"><style>.topnavbarleft { padding: 0px; width:auto; }</style><a target="_blank" href="https://www.hamlineoracle.com/feed/rss/"><div class="alt-header-social social-border sno-rss dashicons dashicons-rss"><span class="icon-hidden-text">RSS Feed</span></div></a><a target="_blank" href="https://vimeo.com/hamlineoracle">
        		<div class="alt-header-social-fa social-border sno-vimeo fa fa-vimeo"><span class="icon-hidden-text">Vimeo</span></div>
        	</a><a target="_blank" href="https://www.instagram.com/hamlineoracle/">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a target="_blank" href="https://twitter.com/HamlineOracle">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a target="_blank" href="https://www.facebook.com/HamlineOracle">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div></div></div><div class="clear"></div><div class="footercredit"><p>&copy; 2020  &bull; <a target='_blank' href='/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://www.hamlineoracle.com/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-46454657-28', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	<div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.hamlineoracle.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.hamlineoracle.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.hamlineoracle.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1.0'></script>
</div><div id="mobile-socialmedia"><div class="sharing sharing-top" data-story-id="7705"><a class='commentscroll' href='https://www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-show'><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.hamlineoracle.com%2F7705%2Fopinion%2Fstaff-editorial-in-response-to-george-floyd%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Staff Editorial: In response to George Floyd&amp;url=https%3A%2F%2Fwww.hamlineoracle.com%2F%3Fp%3D7705" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div></div><div id="sno_hoversearch"><div class="sno-search-close foundation-icons fi-x" style="float:right;"></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://www.hamlineoracle.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button fa fa-search"><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><div class="sharing sharing-top" data-story-id="7705"><a class='commentscroll' href='https://www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-show'><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.hamlineoracle.com%2F7705%2Fopinion%2Fstaff-editorial-in-response-to-george-floyd%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Staff Editorial: In response to George Floyd&amp;url=https%3A%2F%2Fwww.hamlineoracle.com%2F%3Fp%3D7705" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//www.hamlineoracle.com/7705/opinion/staff-editorial-in-response-to-george-floyd//?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Print</span></div></a></div></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://www.hamlineoracle.com/wp-content/uploads/2016/09/web_title_1617-01-3.png" alt="The student news site of Hamline University." /></a></div><div class="hover_title"><div class="hover_titletext">Staff Editorial: In response to George Floyd</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://www.hamlineoracle.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="menu"><ul>
<li class="page_item page-item-25"><a href="https://www.hamlineoracle.com/about/">About the Oracle</a></li>
<li class="page_item page-item-5355"><a href="https://www.hamlineoracle.com/apply-here/">Apply here</a></li>
<li class="page_item page-item-1822"><a href="https://www.hamlineoracle.com/contact/">Contact</a></li>
<li class="page_item page-item-2030"><a href="https://www.hamlineoracle.com/currentpoll/">Current Poll</a></li>
<li class="page_item page-item-7370"><a href="https://www.hamlineoracle.com/magazine-archive/">Magazine Archive</a></li>
<li class="page_item page-item-182"><a href="https://www.hamlineoracle.com/pollsarchive/">pollsarchive</a></li>
<li class="page_item page-item-24"><a href="https://www.hamlineoracle.com/staff/">Staff</a></li>
</ul></div>
</ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
									sharingIconsResize();
					
					jQuery(window).resize(function() {
						sharingIconsResize();
					});
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - jQuery('.footerwrap').height();
				
									WindowHeight -= jQuery('#commentswrap').height();		
								
				
/*
				jQuery('.sno-menu').click(function() {
				
					jQuery('#hoverbar_menu').fadeToggle();
					jQuery('.menu-icon').toggle();
					jQuery('.close-icon').toggle();
					jQuery('#hoverbar_menu').css({ height: jQuery(window).height() - 50 });
				
				});
*/
				
				jQuery(window).scroll(function(event) {
					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
					
	
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
/*
					if ( ScrollPercent > 100 ) {
												jQuery('.sno-arrow-up').css({ background: '#90000', color: '#eee'});
						jQuery('.sno-menu').css({ background: '#90000', color: '#eee'});
						jQuery('.socialmedia .sharing-icon').css({ opacity: 1 })
						
							
					} else {
												jQuery('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
						jQuery('.sno-menu').css({ background: '#eee', color: '#ccc'});
					}
*/
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
															if( jQuery('.subnavbarwrap').length ) {	
									jQuery('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
								}
														
															var lpb = jQuery('.lf_headerleft').width();
																var rpb = 50 + jQuery('.socialmedia').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script></body></html>